Keyboard Shortcuts

Keyboard Shortcuts

Get the most out of Sequel Pro by remembering the following keyboard shortcuts.

Main Tabs

Table Structure ⌘   1
Table Content ⌘   2
Table Relations ⌘   3
Table Info ⌘   4
Custom Query ⌘   5
Table Triggers ⌘   6

General Shortcuts

New Window (Connection File) ⌘   N
New Tab(Connection File) ⌘   T
Add Connection To Favorites ⇧   ⌘   A
Open (Connection File or SQL File) ⌘   O
Open current Connection File in New Window ⌥   ⌘   O
Save (Connection File) ⌘   S
Save As (Connection File) ⇧  ⌘   S
Save Query ^  ⌘   S
Close (Connection File) ⌘   W
Close All (Connection File) ⌥   ⌘   W
Print ⌘   P
Import ⇧   ⌘   I
Show Console Window ⇧   ⌘   K
Clear Console ⌘   K
Back in History ⌃   ⌥   ←
Forward in History ⌃   ⌥   →
Select Next Tab ⌃   ⇥
Select Previous Tab ⌃   ⇧   ⇥
Insert NULL value ⌃   ⇧   N
Copy Create Table Syntax ⇧   ⌘   C
Show Create Table Syntax ⌥   ⌘   S
Refresh Databases ⇧   ⌘   R
Choose Database ⇧   ⌘   D
Show Server Variables ⇧   ⌘   V
Show Server Processes ⌥   ⌘   P
Refresh Tables ⌃   ⌘   R
Flush Privileges ⇧   ⌘   F
User Accounts… ⌘   U
Copy selection / Copy selected row(s) ⌘   C
Copy selected row(s) with column names ⌥   ⌘   C
Copy selected row(s) as SQL INSERT ⌃   ⌥   ⌘   C
Show/Hide Toolbar ⇧   ⌘   T
Filter Table Content ⌃   ⌘   F
Filter Tables ⌃   ⌥   ⌘   F
Bundle Editor ⌃   ⌥   ⌘   B
Navigator ⌃   ⌥   ⌘   N

Select

Select current word ⌃   W
Select current line ⌃   L
Select enclosing brackets ⇧   ⌘   B
Select all ⌘   A

Table Structure Tab

Add a new field ⌥   ⌘   A
Delete selected field
Duplicate selected field ⌘   D
Refresh table structure ⌘   R
Edit table details ⌘   4

Table Content Tab

Add a new row ⌥   ⌘   A
Delete selected row(s)
Duplicate selected row ⌘   D
Refresh table contents ⌘   R

Custom Query Tab

Version 1.0 and later
Run all queries ⌥   ⌘   R
Run current query or selection or ⌘   R
Versions 0.9.9.1 and earlier
Run all queries or ⌘   R
Run current query or selection ⌥   ⌘   R
 
Shift line or selection rightwards ⌘   [
Shift line or selection leftwards ⌘   ]
(Un)Comment line or selection ⌘   /
(Un)Comment current query ⌥   ⌘   /
Completion (narrow-down list / fuzzy search)
    Insertion of an item  ,  , Double-Click
    Insertion full schema reference +  ,     ,    Double-Click
    Keep Window Open after Insertion holding down while insertion
    Fuzzy Search  
    Close Window
Spell Checker Completion (narrow-down list) F5
Select current query ⌃   Y
Show MySQL help for current word or selection ⌃   H
Open query favorites popup menu ⌥   ⌘   F
Open query history popup menu ⌥   ⌘   Y
Insert previous history item (successively) ⌃ +  ↑
Insert next history item (successively) ⌃   ↓
Show all database names as completion list ⌥   ⌘   1
Show all table and view names as completion list ⌥   ⌘   2
Show all table names from current database as completion list ⌥   ⌘   3